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HOW TO
build your own Web site

Build Your Own Web Site
by Niko Coucouvanis

1Make the Map  Launch Dreamweaver MX. The 
program opens a blank document—save the page as 
index.html in Library > WebServer > Documents. Then tell 
Dreamweaver to store your pending images and HTML 

fi les in this same Documents folder; select New Site from the 
Site menu; and in the resulting dialog, click the Basic tab and 
enter a name for your site in the fi eld. Click Next to continue, 
leave the default setting, and click Next again. Select the same 
Documents folder by clicking the folder icon, navigating to it, 
and clicking Choose. Click Next again, select None from the 
server access pop-up menu (we’ll deal with uploading fi les 
later), and click Next to see a summary of your site’s settings. 

Click Done to 
seal the deal.

WHAT YOU NEED
• Dreamweaver MX ($399 or free trial version; 

www.macromedia.com)
• FTP client, such as Transmit ($24.95, 

www.panic.com) or Dreamweaver
• Web host

Stash fi les in Library > WebServer > Documents, 
and you can preview your site from your Mac’s 
built-in Web server. 

2Set the Page  From the Modify menu, select 
Page Properties. In the dialog, type a name for your 
page in the Title fi eld (this is what your visitors 
will see). If you want to display a graphic in the 

background, click the Browse button next to the Background 
Image fi eld, navigate to an image, and click Choose. 
Dreamweaver offers to copy the fi le to the Documents folder—
click Yes, and in the resulting dialog, click New Folder, name 
the folder images, and click Create, then Save. For a solid-color 
background, click the Background swatch and choose a color 
from the palette. If you want to change text or link colors, click 
the appropriate swatch and choose a color. Then click OK.

After we defi ned the 
mapping in step 1, 
Dreamweaver copied our 
background graphic to 
our storage folder.

S o you want a Web page. It’s 2003, for crying out loud—
nobody gives a fart about the Internet since the great dot-
bomb of ’01. But they’ll be back, and this time you’ll be 

there ahead of the pack. Sure, you could just fill in the blanks on could just fill in the blanks on could
your .Mac homepage or click HomePage in iPhoto (or just about 
any modern word- or image-processing app) to autogenerate 

one, but where’s the fun in that? Shouldn’t 
your Web page symbolize your individuality 
and belief in personal freedom? We say, 
“Hell, yeah!” We even show you the way.

You’ve always wanted to fl aunt your fl uff ’n’ 
stuff electronically to the masses, but .Mac 
doesn’t cut it for you. Here, we instruct you on 
how to create a basic home page, complete with a title graphic, 
text, a photo, and navigational links to your unknown treasures 
within. We demonstrate how to Web-optimize photos and build a 
custom-made photo-gallery page. And don’t worry—we also 
tell you how to get everything up on your hosted Web space.

ON THE
DISC

Dreamweaver MX 6.1 Dreamweaver MX 6.1 
trial, GraphicConverter 
4.6.1, Know Thy Code 
supplement, and 
Transmit (OS X) 2.5

Tired of .Mac’s limitations on 
Web-page design, but clueless 
when it comes to code? You can 
quickly build your own site—
code-free—with Dreamweaver.
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Trust us, creating 
HTML tables in 
Dreamweaver 
is much easier 
than coding them 
by hand. Choose a solid color for your table’s background for better 

readability—especially if you have a background graphic.

To title your page, 
insert a graphic logo 
or type text in the 
top cell and then 
center it.

Typing a backslash in the Link fi eld sets a link back to your main index.html page.

3Set the Table  HTML tables allow you to arrange 
images and words into rows and columns, and are 
the best way to design pages that’ll look the same 
across different Web browsers, operating systems, 

and platforms. Thankfully, Dreamweaver can build the tables 
for you; if you’re a budding propellerhead, check out our HTML 
cheat sheet, “Know Thy Code,” on the Disc. In Dreamweaver, 
select the Common tab and click the insert table icon in the 
Insert window. In the resulting dialog, type 2 in the Rows fi eld, 
3 in the Columns fi eld, and 750 in the Width fi eld. Select Pixels 
from the pop-up menu next to Width. To create breathing room 
between cells, type 9 in the Cell Padding fi eld, and then click OK 9 in the Cell Padding fi eld, and then click OK 9
to generate the table.

4Color the Cells  To make your page easy to 
read, choose a background color for the table’s cells. 
In the Properties window, click the Bg Color swatch 
and use the eyedropper to select an easy-on-the-eyes 

color from the palette—we chose white to keep things looking 
clean. To choose a background color that complements your 
background graphic (if you’re displaying one), click the Bg Color 
swatch and use the eyedropper to select any desired color in 
your document window.

5Merge Cells  Since a home page is all about 
self-aggrandizement, a nice big logo or text title that 
loudly announces your arrival to the Web world is par 
for the course. However, one cell is too puny for such 

grandiosity, so merge the top row’s three cells so that your title 
or image runs the width of the table. Click the top-left cell to 
select it, hold down the Shift key, click twice in the adjacent 
cell, and then click the far-right cell to select the entire row (the 
borders will appear in bold). Then click the merge cells icon 
under Row in the Properties window.

6Insert a Title  If you’ve got a logo, click the big 
cell, and then click the image button in the Insert 
window. In the resulting window, navigate to and 
select your logo graphic and click Choose. Click Yes in 

the subsequent dialog. In the next, save the graphic into your 
images folder (create this in the Documents folder if it doesn’t 
already exist). The cell expands to hold your logo—drag any 
bounding-box corner if you need to scale it. If you want a text 
title, click the text-color swatch in the Properties window and 
choose a color. Then select a font from the font pop-up menu, 
click the bold button if you want a heavier line, select a number 
from the Size pop-up, and type a title. To center your logo or title 
in the cell, click the align-center button. Then save your fi le.

You can easily merge cells in HTML tables with the click of a 
button—a task that used to take days to code by hand.

7Show Them the Way Home  Now that you’ve got the basis 
for your home page, use it as a template for your site’s subpages. First, 
create a link for your logo or title so that when surfers click it, they’ll be 
brought back from any page within your site to your home page. Click 

your logo to select it, or highlight your title text. In the Properties window, type a 
backslash (/) in the Link fi eld, which tells the Web browser to go to the site’s root-
level index page. Then select Save As from the File menu, enter a name for the next 
page you want to create (photos.html, bio.html, or what have you), and save it into 
the Documents folder (save a backup too). Repeat for any additional pages.

HIJACK 
YOUR .MAC 
HOMEPAGE
But wait, you say—I use Apple’s .Mac for 
my Web space. Can I have my righteous 
Dreamweaver creation appear as my .Mac 
home page? Sure. Just mount your iDisk by 
selecting iDisk from the Finder’s Go menu. 
Then deposit all of your HTML and image 
fi les in your iDisk’s Sites folder. That’s it—
really. Now anyone can see your handiwork 
by logging onto your .Mac home page. 
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8Make Menu Links  If you want people to 
see your subpages, create menu links on your home 
page to lead them deeper into your site. Go back to 
your home page, click the bottom left cell, then select 

Center from the Horz pop-up menu in the Properties Inspector. 
Then click the text-color swatch, choose a color, select a font 
from the Default Font pop-up menu, select a size from the Size 
pop-up, and type a title that describes your fi rst subpage (such 
as Photo Gallery or About Me). If you want to change the cell’s 
background color, click the Bg Color swatch and select a color 
from the palette. To set the text so it links to its corresponding 
HTML page, click and drag over the text to highlight it, click the 
folder icon next to the Link fi eld, navigate to the fi le, and click 
Choose. If you have more pages, press Return, type more titles 
below the fi rst, and link each title to its corresponding page.

Paragraph text 
fl ows smoothly 
around a right-
aligned image—
pretty slick, eh?

Type titles for your site’s subpages in the bottom left cell to 
create a menu, and then link them to their HTML pages.

9Fill ’Er Up  Now let’s add a pretty picture and 
some compelling content. To add an image (see 
“Optimize Photos,” next page, for important image-
compression info), click the bottom center cell, and 

click the image button. In the resulting dialog, navigate to your 
desired fi le, click Choose, and direct Dreamweaver to copy it 
into the images folder. Feel free to resize the image and change 
its alignment within the cell (we right-aligned ours and then 
typed 5 in the H Space fi eld to move the image 5 pixels away 
from the right). To add text, press your keyboard’s right-arrow 
key to deselect the image, and then start typing—the text will 
fl ow within the same cell. Then apply your page design and 
linking knowledge to your subpages (see “Build Your Own Photo 
Gallery,” next page, for our photo-page tutorial). 

10Leave the Nest  Once you’re fi nished, 
upload your site to your Web host for all the 
world to see. (If you’re a .Mac subscriber, see 
“Hijack Your .Mac Homepage,” p61.) Though 

Dreamweaver lets you upload directly from it, Transmit is easier 
to use (if you’re using Dreamweaver, select Edit Sites from the 
Site menu and apply our instruction to the appropriate panel). 
Launch Transmit. In the right side of the window, enter your 
server address (if you don’t know it, ask your ISP), user name 
(for the server), password, and the path to the folder where you 
want to put your stuff in the corresponding fi elds. Then click 
Connect. In the left side, navigate to your local Web directory 
(Library > WebServer > Documents), Command-click all the fi les 
and folders that comprise your site, and click the upload arrow 
button to send them off. Then fi re up your browser and admire.

Your personal information will vary, but this is where you need to 
enter it to upload fi les.

SERVE YOURSELF
As you build a site, check it out in a browser from time to time. 
Don’t settle for Dreamweaver’s Preview In Browser function. 
Serve the site to yourself on Apache Web Server—it’s installed 
with Mac OS X. Open System Preferences and click Sharing. 
Check the Personal Web Sharing box to start it up. Then launch 
your browser. Because we had you save fi les to the Library > 
WebServer > Documents directory, just enter http://localhost
in the browser’s URL bar, and Apache is smart enough to know 
to look there to fi nd your site.

One little checkmark turns on your Mac’s 
built-in Apache Web Server.
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2Compress  From the File menu, select Save As. 
In the dialog, select JPEG/JFIF (*.JPG, *JPEG) from the 
Format pop-up menu, and click Save. Another dialog 
pops up, allowing you to adjust compression quality. 

Check the Show Preview box to see before-and-after images, 
and check the Calculate File Size box to preview the fi nal 
size. Then use the Quality slider to adjust the amount of JPEG 
compression until you get a good balance of quality and fi le 
size. Click OK to slim down your image.

Optimize Photos
WHAT YOU NEED
• GraphicConverter ($30, www.lemkesoft.com)

1Minimize (Mini-Me-ize)  Instead of 
cramming a bunch of full-screen images onto one Web 
page, pack your gallery page with thumbnail images, 
which viewers can then click to open the full version. 

Follow our instructions in “Optimize Photos,” left, to size down 
and compress an image, and then—with your image still open 
in GraphicConverter—create the thumbnail. From the Picture 
menu, select Size, and then Scale. In the resulting dialog, type 
a number in the Width or Height fi eld so your image ends up 
at 1 by 2 inches (or thereabouts)—that way you can fi t several 

on a page (the ultimate 
dimension is up to you). 
Then select Save As from 
the File menu, and save the 
image with tn or the like in 
the name to distinguish it.

Build Your Own Photo 
Gallery

WHAT YOU NEED
• Dreamweaver MX
• GraphicConverter ($30, www.lemkesoft.com)

For the fastest 
downloads, scale 
down photos before 
you use them on your 
Web page.

After we sized down and compressed our photo, the formerly fat 
25.8MB fi le became a svelte 27.2KB.

If you’re putting photos online, you need to bring down the file 
sizes unless you want visitors complaining about outrageous 

download times. Here’s how to do just that without sacrificing 
too much quality.

1Optimize  Open a photo in GraphicConverter. From 
the Picture menu, select Colors, then Minimize Color 
Table to remove unused colors. Select Size from the 
Picture menu, and then Scale. In the resulting dialog, 

check the Keep Proportions box. Under Size, select Inches from 
both the Width and Height pop-up menus. Then enter a number 
in either the Width or the Height fi eld so that your image is no 
larger than about 4 by 6 inches at 72 dots per inch (the adjacent 
dimension will scale accordingly), and click OK.

We like .Mac’s photo page, but we 
have more control over the layout if 
we make our own.

After you scale down and 
optimize a photo, create a 
miniature version using the 
same principles.

W hy force family and friends to click through pages of 
vacation photos before they find that priceless image of 

your 2 a.m. swim in the Trevi Fountain? Instead, present them 
with a page of thumbnail images, and give them one-click 
access to your most embarrassing moments. 

2Toss ’Em in the Cell  In Dreamweaver, select 
New from the File menu, and click Create in the resulting 
dialog to create a new HTML page. Then follow steps 2 
and 3 of “Build Your Own Web Site,” p60, but create a 

bigger table with more rows and columns. Place all of your photos 
and their thumbnails in the images folder at Library > WebServer >
Documents > images. Then click inside a cell, click the image 
button in the Insert window, navigate to a thumbnail image in 
the resulting dialog, and click Choose to add it. In the Properties 
window, link the thumbnail to its full-size version by clicking the 
folder icon next to the Link fi eld, navigating to the image in the 

dialog, and clicking Choose. Add 
a text title, and then repeat for all 
other thumbnails and links.

   Niko Coucouvanis once coded
   his way out of a paper bag.  Really.   his way out of a paper bag.  Really.


